Pusta lista w oknie „Włącz lub wyłącz funkcje systemu Windows” w 7

Instalowałem ostatnio w Windows 7 x86 Professional pakiet Remote Server Administration Toolkit (RSAT), żeby sobie poadministrować Windows Server Hyper-V 2008R2, który jak wiadomo ma tylko środowisko tekstowe. Przy okazji – pakiet RSAT znajdziecie tu. Po dość typowej instalacji, należy włączyć interesujące składniki z poziomu Panel Sterowania -> Programy i funkcje -> Włącz lub wyłącz funkcje systemu Windows. Po wybraniu tej opcji moim oczom ukazało się okienko:

Po chwili poszukiwań rozwiązania w sieci, trafiłem na elektrodę, gdzie ktoś rozwiązał problem edytując/dodając klucz RegistrySizeLimit w rejestrze . W moim przypadku to nie zadziałało, a jak doczytałem później, nawet nie powinno zadziałać.

Dalsze poszukiwania i natrafiłem na forum fixitpc.pl, prowadzone przez picasso, którą szanuję i cenię za wiedzę jeszcze z forum searchengines.pl. Cały wątek można znaleźć tu, mimo, że u mnie przyczyną pustego okna był inny uszkodzony składnik, to jednak metodyka postępowania jest identyczna, z tą różnicą, że ja musiałem wykonać znacznie mniej operacji. Ale po kolei.
Naprawę zacząłem od odpalenia sfc /scannow w cmd:

I już tu widać ( w logu), gdzie mniej więcej jest problem i nie wszystko udało się naprawić. U mnie uszkodzona była paczka Microsoft-Windows-MediaPlayback-OC-Package.
Kolejne narzędzie, które badania spójność składników systemu to „Narzędzie analizy gotowości aktualizacji systemu”. Tutaj znajduje się zawsze aktualna instalka do Windows 7 x86 – plik 121MB. Kod narzędzia to KB947821. Skanowanie trwa kilkanaście minut:

Wynik działania zapisany w logu, standardowa ścieżka to c:\Windows\Logs\CheckSUR.log – tam znalazłem wpis, że problem został naprawiony. Uruchamiam więc znowu Włącz lub wyłącz funkcje systemu Windows i:

Pełen sukces :).

Wpis “Pusta lista w oknie „Włącz lub wyłącz funkcje systemu Windows” w 7” komentowano 2 razy

  1. Witam.

    Właśnie borykałem się z tym problemem po zainstalowaniu Windows Server i VB2010 i trochę funkcji Win 7 zniknęło.
    Natrafiłem na Twój wpis i teraz wszystko pięknie chodzi.
    Z mojej strony mam pytanie , czemu Win wyłącza niektóre funkcje po instalacji serwera?

Dodaj komentarz